How To Fix A Missing, Disabled Mailbox in Exchange 2013 EAC

Recently I had to deal with a situation where a network engineer had mistakenly right clicked on a user mailbox in the Exchange 2013 EAC (Exchange Admin Center) and chosen disable.  This seemed to hide the mailbox.  The mailbox couldn’t be found through Advanced Search and was essentially missing by all means.  In actual fact, doing this queues the mailbox for deletion.

Fortunately there’s a default retention period of 30 days.  If you’ve accidentally disabled a mailbox (as it’s kind of mislabeled), follow these steps to correct the issue:

  1. In the EAC, navigate to Recipients > Mailboxes.
  2. Click More More Options Icon, and then click Connect a mailbox.

    A list of mailboxes that are disconnected on the selected Exchange server in your Exchange organization will be displayed. This list of disconnected mailboxes includes disabled mailboxes, deleted mailboxes, and soft-deleted mailboxes.

  3. Click the deleted mailbox that you want to connect a user to, and then click Connect.
  4. In the window that asks if you’re sure that you want to connect the mailbox, click Yes.

    A list of user accounts that aren’t mail-enabled is displayed.

  5. Click the user that you want to connect the deleted mailbox to, and then click OK.

    Exchange will connect the deleted mailbox to the user account that you selected.

By default Exchange will prompt you to attach the mailbox to the user account it was deleted from.  I believe it will only do this if another mailbox hasn’t since been attached so it’s still available for selection.

If this article has helped you, please let me know in the comments section below.  This concludes my brief support article.

Advertisements